noch ein problem bei easyUCP

Forum_easyUCP_Desc

Beitragvon AmigaLink » 24. Jun 2005 13:26

den downloads mod popup muss ich nochmal
kontrollieren ...
Die Einstellung speichert nicht.
Du must die SQL-Anweisungen in dem (Preferences) SQL-Block einfügen!

Benutzt du den easyMOD?
Wenn ja, dann gewöhn dir das wieder ab. Denn mal abgesehen davon das der bei plus-boards (und allgemein stark gemoddeten Boards) fehlerhaft eh arbeitet, wäre es mehr als Glück wenn er bei installiertem easyUCP die richtigen stellen finden würde!
Die deutsche Sprache ist Freeware, du kannst sie benutzen, ohne dafür zu bezahlen. Sie ist aber nicht Open Source, also darfst du sie nicht verändern, wie es dir gerade passt.
Benutzeravatar
AmigaLink
Administrator
 
Beiträge: 3987
Registriert: 11. Aug 2004 01:06
Wohnort: NRW

Beitragvon pepi » 24. Jun 2005 13:30

Die Einstellung speichert nicht.
Du must die SQL-Anweisungen in dem (Preferences) SQL-Block einfügen!

Benutzt du den easyMOD?

??? SQL-Anweisungen in dem (Preferences)
nein easy mod benutze ich nicht
gruß Pepi

Bild
Benutzeravatar
pepi
User
 
Beiträge: 116
Registriert: 2. Mai 2005 15:58
Wohnort: Lienz - Austria

Beitragvon AmigaLink » 24. Jun 2005 14:01

Diesen Codeblock meine ich:
Code: Alles auswählen
// Preferences
         if ( $ucp_mode == 'ucp_prefs' || $ucp_mode == '' )
         {
         $sql = "UPDATE " . USERS_TABLE . "
            SET user_viewemail = $viewemail, user_attachsig = $attachsig, user_allowsmile = $allowsmilies, user_allowhtml = $allowhtml, user_allowbbcode = $allowbbcode, user_allow_viewonline = $allowviewonline, user_allow_viewprofile = $allowviewprofile, user_notify = $notifyreply, user_notify_pm = $notifypm, user_popup_pm = $popup_pm, user_timezone = $user_timezone, user_dateformat = '" . str_replace("\'", "''", $user_dateformat) . "', user_lang = '" . str_replace("\'", "''", $user_lang) . "', user_style = $user_style
            WHERE user_id = $user_id";
           if ( !($result = $db->sql_query($sql)) )
           {
              message_die(GENERAL_ERROR, 'Could not update users table', '', __LINE__, __FILE__, $sql);
           }
         }


Ich vermute mal du hast den SQL-Code in diesem Codeblock eigeführt:
Code: Alles auswählen
// Profile Info
         if ( $ucp_mode == 'ucp_info' || $ucp_mode == '' )
         {
         $sql = "UPDATE " . USERS_TABLE . "
            SET user_icq = '" . str_replace("\'", "''", $icq) . "', user_website = '" . str_replace("\'", "''", $website) . "', user_occ = '" . str_replace("\'", "''", $occupation) . "', user_from = '" . str_replace("\'", "''", $location) . "', user_interests = '" . str_replace("\'", "''", $interests) . "',user_aim = '" . str_replace("\'", "''", str_replace(' ', '+', $aim)) . "', user_yim = '" . str_replace("\'", "''", $yim) . "', user_msnm = '" . str_replace("\'", "''", $msn) . "'
            WHERE user_id = $user_id";
           if ( !($result = $db->sql_query($sql)) )
           {
              message_die(GENERAL_ERROR, 'Could not update users table', '', __LINE__, __FILE__, $sql);
           }
         }
Das ist Falsch, da dies der Codeblock für die Profilinformationen ist und nicht der für die Einstellungen!
Zuletzt geändert von AmigaLink am 24. Jun 2005 15:21, insgesamt 1-mal geändert.
Die deutsche Sprache ist Freeware, du kannst sie benutzen, ohne dafür zu bezahlen. Sie ist aber nicht Open Source, also darfst du sie nicht verändern, wie es dir gerade passt.
Benutzeravatar
AmigaLink
Administrator
 
Beiträge: 3987
Registriert: 11. Aug 2004 01:06
Wohnort: NRW

Beitragvon pepi » 25. Jun 2005 00:42

hallo

habe ich jetzt gemacht ...
speichert auch

aber die signatur geht nicht mehr ...
was ist da falsch ???

Zugefügt nach 18 Minute(n):

glaube funktioniert jetzt alles ...

Zugefügt nach 10 Stunde(n) 7 Minute(n):

hi amiga

glaube habe es dank deine anleitungen kapiert :roll: :roll:
danke
gruß Pepi

Bild
Benutzeravatar
pepi
User
 
Beiträge: 116
Registriert: 2. Mai 2005 15:58
Wohnort: Lienz - Austria

Beitragvon AmigaLink » 25. Jun 2005 09:14

Dafür ist die Anleitung ja da. ;)

Ich hoffe mal das ich diese Woche endlich etwas Zeit bekomme um dir noch eben schnell das update auf 1.1.6 zu installieren. :roll:
Die deutsche Sprache ist Freeware, du kannst sie benutzen, ohne dafür zu bezahlen. Sie ist aber nicht Open Source, also darfst du sie nicht verändern, wie es dir gerade passt.
Benutzeravatar
AmigaLink
Administrator
 
Beiträge: 3987
Registriert: 11. Aug 2004 01:06
Wohnort: NRW

Beitragvon pepi » 25. Jun 2005 21:22

das wäre super
danke und ein schönes WE

Zugefügt nach 6 Stunde(n) 34 Minute(n):

ich nochmal

hat das damals garnicht bemerkt hat den
welcome text for reg eingebaut
aber schon lange bevor ich den UCP einbaute
heute wollte ich den wieder einbauen und siehe da
es trat das problem mit der registrierung wieder auf
kann mich nicht registrieren ...

hier mal der code für die user_register.php
der rein sollte ... aber ist kein muss für
mich den einzubauen aber nur dass du weisst sollte mal
ein andere das selber prob haben wie ich

Code: Alles auswählen
    // START - SEND PM ON REGISTER MOD - AbelaJohnB
   //
   // According to 'netclectic' we need to set the datastamp to '9999999999' in order to
   // insure the pop-up notification about a new message existing. I concur with 'netclectic'
   // and have thus made the change to his suggestion. Thanks netclectic!
        //
   $sql = "UPDATE " . USERS_TABLE . "
      SET user_new_privmsg = '1', user_last_privmsg = '9999999999'
            WHERE user_id = $user_id";
      if ( !($result = $db->sql_query($sql)) )
        {
          message_die(GENERAL_ERROR, 'Could not update users table', '', __LINE__, __FILE__, $sql);
        }

        $register_pm_subject = $lang['register_pm_subject'];
        $register_pm = $lang['register_pm'];
        $privmsgs_date = date("U");
        $sql = "INSERT INTO " . PRIVMSGS_TABLE . " (privmsgs_type, privmsgs_subject, privmsgs_from_userid, privmsgs_to_userid, privmsgs_date, privmsgs_enable_html, privmsgs_enable_bbcode, privmsgs_enable_smilies, privmsgs_attach_sig) VALUES ('0', '" . str_replace("\'", "''", addslashes(sprintf($register_pm_subject,$board_config['sitename']))) . "', '2', " . $user_id . ", " . $privmsgs_date . ", '0', '1', '1', '0')";
        if ( !$db->sql_query($sql) )
      {
         message_die(GENERAL_ERROR, 'Could not insert private message sent info', '', __LINE__, __FILE__, $sql);
      }

      $privmsg_sent_id = $db->sql_nextid();
      $privmsgs_text = $lang['register_pm_subject'];
        //
        $sql = "INSERT INTO " . PRIVMSGS_TEXT_TABLE . " (privmsgs_text_id, privmsgs_text) VALUES ($privmsg_sent_id, '" . str_replace("\'", "''", addslashes(sprintf($register_pm,$board_config['sitename'],$board_config['sitename']))) . "')";
        if ( !$db->sql_query($sql) )
      {
         message_die(GENERAL_ERROR, 'Could not insert private message sent text', '', __LINE__, __FILE__, $sql);
      }
        // END - SEND PM ON REGISTER MOD - AbelaJohnB


oder vielleicht ist bei dem code ein fehler drin damit man den
dann doch verwenden kann

bis dann
gruß Pepi

Bild
Benutzeravatar
pepi
User
 
Beiträge: 116
Registriert: 2. Mai 2005 15:58
Wohnort: Lienz - Austria

Beitragvon AmigaLink » 25. Jun 2005 22:05

Vorweg, ich nutze den WPM von Duvelske auf EmF ohne Probleme.

Häng mir doch bitte den von AbelaJohnB mal an, damit ich ihn mir mal näher betrachten kann.
Die deutsche Sprache ist Freeware, du kannst sie benutzen, ohne dafür zu bezahlen. Sie ist aber nicht Open Source, also darfst du sie nicht verändern, wie es dir gerade passt.
Benutzeravatar
AmigaLink
Administrator
 
Beiträge: 3987
Registriert: 11. Aug 2004 01:06
Wohnort: NRW

Beitragvon pepi » 26. Aug 2005 15:14

AmigaLink hat geschrieben:Vorweg, ich nutze den WPM von Duvelske auf EmF ohne Probleme..


hallo amiga

ja den habe ich jetzt auch installiert und funktioniert super

hier der von AbelaJohnB ...

Zugefügt nach 61 Tag(en) 2 Stunde(n) 42 Minute(n):

hi amiga

ich mal wieder
habe den cash mod eingebaut
aber leider zeigt er mir im profil keinen cash an

kann mir dabei helfen ???
bis dann
Dateianhänge
Send PM on Registration.rar
Send PM on Registration
(4.76 KiB) 380-mal heruntergeladen
gruß Pepi

Bild
Benutzeravatar
pepi
User
 
Beiträge: 116
Registriert: 2. Mai 2005 15:58
Wohnort: Lienz - Austria

Beitragvon AmigaLink » 26. Aug 2005 15:38

Neues Problem = neuen thread bitte!!! Bild

DANKE ;)
Die deutsche Sprache ist Freeware, du kannst sie benutzen, ohne dafür zu bezahlen. Sie ist aber nicht Open Source, also darfst du sie nicht verändern, wie es dir gerade passt.
Benutzeravatar
AmigaLink
Administrator
 
Beiträge: 3987
Registriert: 11. Aug 2004 01:06
Wohnort: NRW

Vorherige

Zurück zu easy UCP



Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

cron